在hadoop集群上编译类jar包,因jdk版本不同出现的异常

云计算 waitig 553℃ 百度已收录 0评论

Exception in thread "main" java.lang.UnsupportedClassVersionError: com/fuben/hadoop/test/Test : Unsupported major.minor version 52.0

这里写图片描述

可以看出是jdk版本不同产生的异常
分别查看liunux的jdk版本和编译器的jdk版本,两者版本一致
这里写图片描述

那么就是类jar包的版本不一致
打开myeclipse,选择 Window–>Preferences–>java–>Compiler

这里写图片描述

修改后重新生成class jar包,在hadoop’集群上运行成功


本文由【waitig】发表在等英博客
本文固定链接:在hadoop集群上编译类jar包,因jdk版本不同出现的异常
欢迎关注本站官方公众号,每日都有干货分享!
等英博客官方公众号
点赞 (0)分享 (0)