安装bison时出现Glibc 2.9 – 2.12 and GNU M4 1.4.11 – 1.4.15 have another strstr bug.

数据库 waitig 724℃ 百度已收录 0评论

首先我这边是安装mysql5.7时需要bison这个包,但是在安装这个包时候出现了Glibc 2.9 – 2.12 and GNU M4 1.4.11 – 1.4.15 have another strstr bug.错误以下:


解决办法

1.下载并安装一个M4包

#wget -O m4-1.4.9.tar.gz http://ftp.gnu.org/gnu/m4/m4-1.4.9.tar.gz

2.下载完成后解压

#tar -zvxf m4-1.4.9.tar.gz && cd m4-1.4.9

3.编译并安装

#./configure && make && make install

安装完后我们继续安装bison

#cd bison-3.0.4/ && ./configure && make && make install

这时候我们发现已经成功的安装


安装完成后我们查看上一条命令是否执行成功


此时就已经安装成功了,希望对您有所帮助~




本文由【waitig】发表在等英博客
本文固定链接:安装bison时出现Glibc 2.9 – 2.12 and GNU M4 1.4.11 – 1.4.15 have another strstr bug.
欢迎关注本站官方公众号,每日都有干货分享!
等英博客官方公众号
点赞 (0)分享 (0)