阿里云CentOS7中安装Python3.6

系统运维 waitig 676℃ 百度已收录 0评论

安装python3.6可能使用的依赖

# yum install openssl-devel bzip2-devel expat-devel gdbm-devel readline-devel sqlite-devel

 

下载python3.6编译安装

使用make altinstall,使用make install在系统中将会有两个不同版本的Python在/usr/bin/目录中,会导致很多不好处理的问题。

# wget https://www.python.org/ftp/python/3.6.0/Python-3.6.0.tgz

# tar -xzvf Python-3.6.0.tgz

# cd Python-3.6.0/

把Python3.6安装到 /usr/local 目录

# ./configure –prefix=/usr/local

# make

# make altinstall

 

更改/usr/bin/python链接

# cd/usr/bin

# mv python python.bak

# ln -s /usr/local/bin/python3.6 /usr/bin/python

# ln -s /usr/local/bin/python3.6 /usr/bin/python3

 

更改yum脚本的python依赖

# cd /usr/bin/yum

#!/usr/bin/python 改为 #!/usr/bin/python2

以下两处待以后确认:(有人说要配置,在笔者的系统中没有配置这两项)

yum yum-config-manager yum-debug-restore yum-groups-manager

yum-builddep yum-debug-dump yumdownloader

 

修改urlgrabber配置文件

# vi /usr/libexec/urlgrabber-ext-down

#!/usr/bin/python 改为 #!/usr/bin/python2


本文由【waitig】发表在等英博客
本文固定链接:阿里云CentOS7中安装Python3.6
欢迎关注本站官方公众号,每日都有干货分享!
等英博客官方公众号
点赞 (0)分享 (0)