Intel MKL FATAL ERROR: Cannot load libmkl_avx2.so or libmkl_def.so.

系统运维 waitig 797℃ 百度已收录 0评论

之前在运行一个文件时,发生了这个问题,排查了一下是wineModel = LassoCV(cv=10).fit(X, Y)
这行代码组成的.

Intel MKL FATAL ERROR: Cannot load libmkl_avx2.so or libmkl_def.so.
英特尔MKL致命错误:不能加载libmkl_avx2。所以还是libmkl_def.so

刚看到这个错误确实吓了我一跳,怎么都出现底层错误了.

这是一只熊猫
(嘴上笑嘻嘻,心里MMP)

不过仔细想想mkl确实是一个python的底层类库.
百度了一下,似乎一般都是在运行scikit-learn或者其他需要运行cude的类库比如Theano,keras之类的.

解决方案,建议更新你使用类库的的所有依赖包,尤其是mkl.或者直接所有类库也行

pip install --upgrade scikit-learn
# 或者
conda upgrade scikit-learn

到这我就已经解决问题了,但是使用CUDE的似乎还有可能,也不知道管不管用,但是你可以试着阅读下面这篇博客:
http://xuhaijiao.blog.51cto.com/7977742/1894964


本文由【waitig】发表在等英博客
本文固定链接:Intel MKL FATAL ERROR: Cannot load libmkl_avx2.so or libmkl_def.so.
欢迎关注本站官方公众号,每日都有干货分享!
等英博客官方公众号
点赞 (0)分享 (0)